家里监控的主机扩容,零几年买的一台老主机了,偶然看到桌面图标有个熟悉又陌生的图标“易”。打开一看才知道是 当年跟着视频学习做软件,最后吃灰的《易语言》。
搜刮了一下记忆,做了个小软件玩,感觉还不错吧!


演示动画

yyy
拖入一个程序来获取这个程序的.ico图标


程序编写

其实写法很简单,而且是中文的命令。
1
新建了一个空白程序,拖了两个组件:透明标签、拖放对象
透明标签无意义,只是起到文本提示的作用;拖放对象是用来外部拖入文件时获取文件的路径。
2
下面就写了几条"代码" 中文编程多少有点不伦不类的。
3
这里考虑到了桌面会有快捷方式(.lnk) 所以加了判断,置随机数种子是防止重名。
最后编译生成.exe文件即可运行!


代码分享

.版本 2
.支持库 edroptarget
.支持库 eAPI

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

拖放对象1.注册拖放控件 (取窗口句柄 ())
置随机数种子 ()

.子程序 _拖放对象1_得到文件
.参数 接收到的文件路径, 文本型

.判断开始 (取文本右边 (接收到的文件路径, 4) = “.lnk”)
    提取资源文件图标 (取快捷方式目标 (接收到的文件路径, , , , , , , ), 0, 取运行目录 () + “\” + 到文本 (取随机数 (, )) + “.ico”, 1)
.判断 (取文本右边 (接收到的文件路径, 4) = “.exe”)
    提取资源文件图标 (接收到的文件路径, 0, 取运行目录 () + “\” + 到文本 (取随机数 (, )) + “.ico”, 1)
.默认